(Untitled)

Ficha DSN de usuario

Agrega, elimina o configura orígenes de datos con nombres de origen de datos (DSN) de usuario. Estos orígenes de datos son locales para un equipo y sólo puede obtener acceso el usuario actual.

Control | Descripción
Orígenes de datos de usuario | Muestra todos los DSN de usuario, incluyendo el nombre de cada DSN y el controlador asociado al DSN. Al hacer doble clic en un DSN de usuario, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.
Agregar | Haga clic para agregar un nuevo origen de datos de usuario. En el cuadro de diálogo Crear nuevo origen de datos que aparece, seleccione el controlador para el que está agregando un origen de datos de usuario y haga clic en Finalizar. Aparece el cuadro de diálogo de configuración específico del controlador.
Quitar | Haga clic para quitar de la lista Orígenes de datos de usuario el origen de datos de usuario seleccionado.
Configurar | Haga clic para cambiar la configuración del origen de datos de usuario seleccionado. Se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.
Aceptar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC. No se tiene que presionar Aceptar para aceptar los cambios en la lista Orígenes de datos de usuario. Los cambios en la lista ya se han aceptado al hacer clic en el botón Aceptar en el cuadro de diálogo de configuración del origen de datos.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC pero no deshace los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


.topic 902
Muestra todos los DSN de usuario, incluyendo el nombre de cada DSN y el controlador asociado al DSN. Al hacer doble clic en un DSN de usuario, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.

.topic 903
Haga clic para cambiar la configuración del origen de datos de usuario seleccionado.

.topic 904
Haga clic para agregar un nuevo origen de datos de usuario.

.topic 905
Haga clic para quitar el origen de datos de usuario seleccionado.

.topic 910
Muestra todos los DSN de sistema, incluyendo el nombre de cada DSN y el controlador asociado al mismo. Al hacer doble clic en un DSN de sistema, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.

.topic 911
Haga clic para cambiar la configuración del origen de datos de sistema seleccionado.

.topic 912
Haga clic para agregar un nuevo origen de datos de sistema.

.topic 913
Haga clic para quitar el origen de datos de sistema seleccionado.

.topic 915
Presenta todos los DSN de archivo y los subdirectorios contenidos dentro del directorio indicado en el cuadro Buscar en. Al hacer doble clic en un DSN de archivo, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.

.topic 916
Haga clic para cambiar la configuración del origen de datos del archivo seleccionado.

.topic 917
Haga clic para agregar un nuevo origen de datos de archivo.

.topic 918
Haga clic para quitar el origen de datos de archivo seleccionado.

.topic 919
Establece como predeterminado el directorio indicado en el cuadro Buscar en cuando se ejecuta Administrador de ODBC.

.topic 920
Presenta el directorio para el que se muestran los subdirectorios y DSN de archivo en la ventana que está debajo.

.topic 921
Sustituye el directorio indicado en el cuadro Buscar en con el directorio ubicado en el nivel superior.

.topic 969
Muestra cada uno de los controladores de ODBC junto con su opción de tiempo de espera del conjunto de conexiones. Para establecer la opción de tiempo de espera, haga doble clic en el nombre del controlador ODBC.

.topic 965
El nombre, la versión, la empresa, el nombre de archivo y la fecha de actualización de cada controlador ODBC instalado.

.topic 924
Permite establecer las opciones de traza para la aplicación.

.topic 926
Habilita la traza dinámica continua, con o sin conexión, mientras se muestra el cuadro de diálogo Administrador de orígenes de datos ODBC o hasta hacer clic en Detener el seguimiento ahora. (Este botón alterna entre Comenzar el seguimiento ahora y Detener el seguimiento ahora.)

.topic 923
Activa Visual Studio Analyzer, que permanece habilitado hasta que se hace clic en Detener Visual Studio Analyzer. (Este botón cambia entre Iniciar Visual Studio Analyzer y Detener Visual Studio Analyzer.)

.topic 927
Presenta la ruta de acceso y el nombre de archivo donde se almacena la información de traza. El archivo de registro predeterminado es sql.log.

.topic 968
Seleccione la ruta y el nombre de archivo para el archivo de registro.

.topic 928
Escriba la ruta y nombre de archivo adecuados para seleccionar un archivo .dll de traza personalizado.

.topic 929
Examina la estructura de directorios en busca de una DLL de traza personalizada.

.topic 952
Presenta todos los DSN de archivo y los subdirectorios contenidos dentro del directorio indicado en el cuadro Buscar en. Al hacer doble clic en un DSN se conecta con el origen de datos.

.topic 953
Indica el directorio para el que se muestran los subdirectorios y DSN de archivo en la ventana que está debajo.

.topic 954
Sustituye el directorio indicado en el cuadro Buscar en con el directorio ubicado en el nivel superior.

.topic 955
Muestra el nombre DSN del archivo tanto si se selecciona de la lista Orígenes de datos de archivo como si se escribe manualmente.

.topic 957
Haga clic para agregar un nuevo origen de datos de archivo.

.topic 961
Muestra todos los DSN de usuario o de sistema e incluye el nombre y tipo de cada DSN. Al hacer doble clic en un DSN se conecta con el origen de datos.

.topic 970
Muestra el periodo de tiempo de espera, en segundos, para un controlador seleccionado.

.topic 974
Establece el control del rendimiento de la conexión para depurar pero afecta al rendimiento de la aplicación.

.topic 971
Habilita la supervisión del rendimiento de la conexión.

.topic 972
Deshabilita la asignación del rendimiento de la conexión.

.topic 973
Especifica el tiempo de espera para volver a intentar la conexión en segundos.

.topic 962
Haga clic para agregar un nuevo origen de datos de equipo.


Ficha Acerca de

Presenta información acerca de los componentes principales de ODBC: incluye el Administrador de controladores, la biblioteca de cursores, la DLL de instalación y los demás archivos que forman parte de los componentes principales.

Control | Descripción
Lista de los componentes principales | La descripción, versión, nombre de archivo y la ubicación de cada componente principal de ODBC.
Aceptar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC pero no deshace los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha Conjunto de conexiones

Le permite modificar el tiempo de espera para volver a intentar la conexión y el intervalo del tiempo de espera de la conexión para un controlador seleccionado cuando utiliza un conjunto de conexiones. También le permite habilitar y deshabilitar el control del rendimiento, que registra un número de estadísticas de conexión. El conjunto de conexiones permite que su aplicación utilice una de las conexiones del conjunto de conexiones sin tener que establecerla cada vez. Cuando se crea una conexión y se incluye en un conjunto, una aplicación puede reutilizar la conexión sin realizar todo el proceso de conexión; así mejora el rendimiento.

Control | Descripción
Controladores ODBC | Muestra cada uno de los controladores de ODBC junto con su opción de tiempo de espera del conjunto de conexiones. Para establecer la opción de tiempo de espera, haga doble clic en el nombre del controlador ODBC.
Tiempo de espera de agrupación de conexiones | Establece el tiempo de espera del conjunto de conexiones, en segundos para el controlador seleccionado. Para establecer los atributos de agrupación de conexiones, haga doble clic en el nombre del controlador. Aparece el cuadro de diálogo Establecer los atributos de agrupación de conexiones. Puede establecer el tiempo de permanencia en el conjunto de las conexiones no utilizadas y activar el conjunto de conexiones del controlador seleccionado.
Habilitar | Habilita los contadores de supervisión del rendimiento del conjunto de conexiones. Para obtener más información sobre supervisión del rendimiento, consulte ODBC Programmer's Reference.
Deshabilitar | Desahabilita los contadores de control del rendimiento del conjunto de conexiones. Para obtener más información sobre supervisión del rendimiento, consulte ODBC Programmer's Reference.
Tiempo de espera de reintento | Especifica, en segundos y con menos de seis dígitos, el tiempo máximo de espera para que el Administrador de controladores ODBC vuelva a intentar la conexión con el servidor de bases de datos.
Aceptar | Acepta los cambios en la configuración del conjunto de conexiones y cierra el cuadro de diálogo Administrador de orígenes de datos ODBC.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC sin aceptar los cambios en la configuración.
Aplicar | Acepta los cambios en la configuración del conjunto de conexiones y deja abierto el cuadro de diálogo Administrador de orígenes de datos ODBC.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha Origen de datos de archivo

Le permite conectarse a un origen de datos que tiene nombres de origen de datos (DSN) de archivo. Un origen de datos de archivo, no necesariamente destinado al usuario ni local en un equipo, se puede compartir entre todos los usuarios que tienen instalados los mismos controladores.

Control | Descripción
Origen de datos de archivo | Presenta todos los DSN de archivo y los subdirectorios contenidos dentro del directorio indicado en el cuadro Buscar en. Al hacer doble clic en un DSN se conecta con el origen de datos.
Buscar en | Muestra el directorio para el que se presentan los subdirectorios y DSN de archivo en la ventana que está debajo. Al hacer clic en la flecha hacia abajo que está al lado del cuadro de texto se presenta la estructura de directorios completa.
Icono Subir un nivel | Sustituye el directorio indicado en el cuadro Buscar en con el directorio ubicado en el nivel inferior.
Nombre de DSN | Muestra el nombre del DSN de archivo tanto si se selecciona de la lista Orígenes de datos de archivo como si se escribe manualmente.
Nuevo | Haga clic para agregar un nuevo origen de datos de archivo. En el cuadro de diálogo Crear nuevo origen de datos que aparece, seleccione el controlador para el que está agregando un origen de datos de archivo y haga clic en Siguiente para especificar el nombre o ubicación del nuevo DSN de archivo. Haga clic en Siguiente de nuevo para ver un resumen de la nueva información. Después de que elija Detener, se presenta un cuadro de diálogo de configuración específico del controlador.
Aceptar | Cierra el cuadro de diálogo Seleccionar origen de datos y conecta al origen de datos de archivo que está indicado en el cuadro de texto Nombre de DSN. No se tiene que hacer clic en Aceptar para aceptar los cambios en la lista Orígenes de datos de archivo. Los cambios en la lista ya se han aceptado al hacer clic en el botón Aceptar en el cuadro de diálogo de Configuración del origen de datos.
Cancelar | Cierra el cuadro de diálogo Seleccionar origen de datos sin conectarse con el origen de datos de archivo y sin deshacer los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha DSN de archivo

Agrega, elimina o configura orígenes de datos de archivo que pueden compartir todos los usuarios que tienen instalados los mismos controladores. Estos orígenes de datos no necesitan estar dedicados a un usuario ni ser locales en un equipo.

Control | Descripción
Orígenes de datos de archivo | Presenta todos los nombres de origen de datos de archivo (DSN) y los subdirectorios contenidos dentro del directorio indicado en el cuadro Buscar en. Al hacer doble clic en un DSN de archivo, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.
Agregar | Haga clic para agregar un nuevo origen de datos de archivo. En el cuadro de diálogo Crear nuevo origen de datos que aparece, seleccione el controlador para el que está agregando un origen de datos de archivo y haga clic en Siguiente para especificar el nombre o ubicación del nuevo origen de datos de archivo. Haga clic en Siguiente de nuevo para ver un resumen de la nueva información de origen de datos. Después de que elija Detener, se presenta un cuadro de diálogo de configuración específico del controlador.
Quitar | Quita el origen de datos de archivo seleccionado. Debe seleccionar el origen de datos de archivo que desea quitar de la lista antes de hacer clic en Quitar.
Configurar | Haga clic para cambiar la configuración del origen de datos del archivo seleccionado. Debe seleccionar el nombre de un origen de datos de archivo de la lista antes de hacer clic en Configurar. Presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.
Establecer directorio | Establece como predeterminado el directorio indicado en el cuadro Buscar en cuando se ejecuta Administrador de ODBC.
Buscar en | Presenta el directorio para el que se presentan los subdirectorios y DSN de archivo en la ventana que está debajo. Al hacer clic en la flecha hacia abajo que está al lado del cuadro de texto se presenta la estructura de directorios completa. El directorio predeterminado que se presenta inicialmente cuando se ejecuta el Administrador de ODBC por primera vez se guarda en la información del sistema pero se puede cambiar con el botón Establecer directorio.
Icono Subir un nivel | Sustituye el directorio indicado en el cuadro Buscar en con el directorio ubicado en el nivel inferior.
Aceptar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC. No se tiene que hacer clic en Aceptar para aceptar los cambios en la lista Orígenes de datos de archivo. Los cambios en la lista ya se han aceptado al hacer clic en el botón Aceptar en el cuadro de diálogo de configuración del origen de datos.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC pero no deshace los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha Origen de datos de equipo

Le permite conectar con un origen de datos que tiene un nombre de origen de datos (DSN) de usuario o un DSN de sistema. Los orígenes de datos de equipo son específicos para este equipo y no se pueden compartir.

Control | Descripción
Origen de datos de equipo | Muestra todos los DSN de usuario o de sistema e incluye el nombre y tipo de cada DSN. Al hacer doble clic en un DSN se conecta con el origen de datos.
Nuevo | Haga clic para agregar un nuevo origen de datos de equipo. En el cuadro de diálogo Crear nuevo origen de datos que aparece, seleccione el controlador para el que está agregando un origen de datos de archivo y haga clic en Siguiente para especificar el nombre o ubicación del nuevo DSN. Haga clic en Siguiente de nuevo para ver un resumen de la nueva información. Después de que elija Detener, se presenta un cuadro de diálogo de configuración específico del controlador.
Aceptar | Cierra el cuadro de diálogo Seleccionar origen de datos y se conecta con el origen de datos seleccionado. Al hacer clic en Aceptar no se aceptan los cambios en la lista Orígenes de datos de equipo. Los cambios en la lista ya se han aceptado al hacer clic en el botón Aceptar en el cuadro de diálogo de Configuración del origen de datos.
Cancelar | Cierra el cuadro de diálogo Seleccionar origen de datos sin conectarse con el origen de datos de archivo y sin deshacer los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha Controladores

Presenta información acerca de los controladores ODBC instalados en el equipo. No puede realizar ninguna acción desde esta ficha. Debe utilizar el programa de configuración específico del controlador para agregar o quitar controladores ODBC.

Control | Descripción
Controladores ODBC | El nombre, la versión, la empresa, el nombre de archivo y la fecha de creación de archivo de cada controlador ODBC del equipo.
Aceptar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha DSN de sistema

Agrega, elimina o configura orígenes de datos con nombres de origen de datos (DSN) de sistema. Estos orígenes de datos son locales para el equipo pero no están destinados al usuario. Cualquier usuario con los permisos adecuados puede obtener acceso al DSN de sistema.

Control | Descripción
Orígenes de datos de sistema | Muestra todos los DSN de sistema, incluyendo el nombre de cada DSN y el controlador asociado al mismo. Al hacer doble clic en un DSN de sistema, se presenta el cuadro de diálogo de configuración de origen de datos específico del controlador.
Agregar | Haga clic para agregar un nuevo origen de datos de sistema. En el cuadro de diálogo Crear nuevo origen de datos que aparece, seleccione el controlador para el que está agregando un origen de datos de sistema y haga clic en Finalizar. Aparece el cuadro de diálogo de configuración específico del controlador.
Quitar | Quita de la lista Orígenes de datos de sistema el nombre de origen de datos de sistema seleccionado.
Configurar | Haga clic para cambiar la configuración del origen de datos de sistema seleccionado. Presenta el cuadro de diálogo de configuración de origen de datos específico del controlador que le permite cambiar la configuración de un origen de datos de sistema existente. Debe seleccionar el nombre de un origen de datos de sistema de la lista antes de hacer clic en el botón Configurar.
Aceptar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC. No tiene que hacer clic en Aceptar para aceptar los cambios en la lista Orígenes de datos de sistema. Los cambios en la lista ya se han aceptado al hacer clic en el botón Aceptar en el cuadro de diálogo de configuración del origen de datos.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC pero no deshace los cambios realizados con los controles de otro cuadro de diálogo.
Ayuda | Presenta esta pantalla de Ayuda.


Ficha Traza

Especificar cómo realizará el Administrador de controladores ODBC la traza de las llamadas a funciones de ODBC. El Administrador de controladores puede realizar el seguimiento de llamadas continuamente o sólo para una conexión; puede realizar la traza dinámicamente o puede permitir que sea realizada por una DLL de traza personalizada.

Control | Descripción
Comenzar el seguimiento ahora/Detener el seguimiento ahora (alterna) | Habilita el seguimiento dinámico continuo, con o sin conexión, mientras se muestra el cuadro de diálogo Administrador de orígenes de datos ODBC o hasta hacer clic en Detener el seguimiento ahora.
Iniciar Visual Studio Analyzer/Detener Visual Studio Analyzer (alterna) | Habilita Visual Studio Analyzer, que permanece habilitado hasta que se hace clic en Detener Visual Studio Analyzer. Visual Studio Analyzer es una herramienta que puede utilizar para depurar y analizar su aplicación distribuida. Para obtener más información sobre Visual Studio Analyzer, consulte la documentación de MSDN Library.
Ruta del archivo de registro | Presenta la ruta de acceso y el nombre de archivo donde se almacena la información de traza. Utilice la ruta de acceso y el nombre de archivo (sql.log) predeterminados o, de forma alternativa, especifique un archivo nuevo escribiendo cualquier otra ruta de acceso o nombre de archivo, o haciendo clic en Examinar y seleccionando un directorio y un archivo.
Examinar | Le permite seleccionar la ruta de acceso y el nombre de archivo para el archivo de registro examinando los directorios del equipo.
DLL de traza personalizada | Le permite seleccionar un archivo .dll distinto de Odbctrac.dll para realizar el seguimiento. Escriba la ruta de acceso y el nombre de archivo de la DLL personalizada o haga clic en Seleccionar DLL para examinar los directorios. El archivo Odbctrac.dll que se entrega con MDAC SDK se puede reemplazar con la DLL personalizada que desee.
Seleccionar DLL | Permite al usuario examinar la estructura de directorios para buscar una DLL de traza personalizada. La ruta de acceso y el nombre de archivo de la DLL seleccionado aparecerán en el cuadro de texto DLL de traza personalizada.
Aceptar | Acepta los cambios en las configuraciones de la Ruta del archivo de seguimiento y la DLL de seguimiento personalizada y cierra el cuadro de diálogo Administrador de orígenes de datos ODBC.
Cancelar | Cierra el cuadro de diálogo Administrador de orígenes de datos ODBC sin aceptar los cambios en la configuración.
Aplicar | Acepta los cambios en la configuración del seguimiento y mantiene abierto el cuadro de diálogo Administrador de orígenes de datos ODBC.
Ayuda | Presenta esta pantalla de Ayuda.


Cuadro de diálogo Seleccionar traductor

El cuadro de diálogo Seleccionar traductor muestra las DLL de traducción instaladas y le permite seleccionar una para permitir que el controlador traduzca datos de un juego de caracteres a otro. La aplicación y el origen de datos a menudo almacenan los datos con juegos de caracteres diferentes. ODBC proporciona un mecanismo general que permite al controlador traducir los datos de un juego de caracteres a otro.

Después de especificar una DLL de traducción, el controlador la carga y llama para traducir los datos entre la aplicación y el origen de datos. Esto incluye a todas las sentencias SQL y parámetros de caracteres que se envían al origen de datos, los caracteres resultantes, los metadatos de caracteres como los nombres de las columnas y los mensajes de error que se obtienen del origen de datos. Los datos de conexión no se traducen ya que la DLL de traducción no se carga hasta que la aplicación se conecta al origen de datos.

La DLL de traducción que implementa las funciones SQLDriverToDataSource y SQLDataSourceToDriver, a las que llama el controlador, puede ser escrita por el desarrollador de la aplicación, el desarrollador del controlador u otra parte.

Para obtener más información sobre DLL de traducción, consulte la ODBC Programmer's Reference.